Capítulo 3. Ejecutar aplicaciones Symfony

Como se ha visto en los capítulos anteriores, el framework Symfony está formado por un conjunto de archivos escritos en PHP. Los proyectos realizados con Symfony utilizan estos archivos, por lo que la instalación de Symfony consiste en obtener esos archivos y hacer que estén disponibles para los proyectos.

La versión mínima de PHP requerida para ejecutar Symfony es PHP 5.2.4. Asegúrate de disponer al menos de esa versión ejecutando lo siguiente en la línea de comandos del sistema operativo:

$ php -v
 
PHP 5.3.1 (cli) (built: Jan  6 2010 20:54:10) 
Copyright (c) 1997-2009 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2009 Zend Technologies

Si el número de versión que se muestra es 5.2.4 o superior, ya puedes instalar Symfony tal y como se explica en este capítulo.