Ver índice de contenidos del libro

1.6. Prerrequisitos

En primer lugar, es imprescindible que cuentes con un entorno de desarrollo web que funcione correctamente y esté formado por un servidor web (Apache por ejemplo), un gestor de bases de datos (MySQL, PostgreSQL o SQLite por ejemplo) y PHP versión 5.2.4 o superior.

Como vamos a utilizar mucho la línea de comandos, te aconsejamos que utilices un sistema operativo tipo Unix. No obstante, todo lo que vamos a ver también funciona perfectamente en Windows, por lo que puedes ejecutar los comandos en la consolas cmd.

Nota Los comandos de las consolas tipo Unix te pueden venir muy bien en un entorno Windows. Si quieres hacer uso de comandos como tar, gzip o grep en Windows, puedes instalar Cygwin. Como la documentación oficial es muy escasa, te aconsejamos que utilices alguna buena guía de instalación de Cygwin. Si eres de los valientes, también puedes probar los Windows Services for Unix de Microsoft.

Como este tutorial sólo se centra en el framework Symfony, suponemos que tienes unos sólidos conocimientos de PHP 5 y de la programación orientada a objetos.