Ver índice de contenidos del libro

2.2. Versiones de Python

El nucleo del framework Django (versión 1.4 y superior) funciona con cualquier versión de Python superior a la 2.5 hasta la 2.7, ambas inclusive. El soporte opcional para GIS (Sistemas de Información Geográfica) requiere Python 2.5 a 2.7.

Si no estás seguro de qué versión de Python debes instalar y tienes completa libertad de decisión, debes elegir la version mas reciente en la serie 2.x:, la versión 2.7.

Aunque Django funciona igual de bien con cualquier versión de 2.5 a 2.7, las últimas versiones de Python tienen mejoras en el rendimiento y poseen características de idiomas adicionales que puedes utilizar en tus aplicaciones. Además, ciertos complementos de terceros que desees utilizar pueden requerir una nueva versión de Python 2.5, por lo que el uso de una versión posterior de Python mantiene tus opciones abiertas.