Ver índice de contenidos del libro

5.9. La propiedad minimum-stability

El valor de esta propiedad se emplea al filtrar los paquetes por su estabilidad. El valor por defecto es stable, por lo que si necesitas alguna dependencia en estado dev, debes indicarlo en la propia dependencia o no se instalará.

Al instalar/actualizar los paquetes, se comprueba la versión de cada uno y si es inferior a la estabilidad de minimum-stability, ese paquete no se instala. Puedes modificar la estabilidad de cada paquete que declares en require y require-dev tal y como se explicó en la anterior sección enlazando paquetes.

Los valores disponibles para esta opción por orden ascendente de estabilidad son dev, alpha, beta, RC y stable.