Ver índice de contenidos del libro

4.5. El comando update

El comando update instala las versiones más recientes disponibles de tus dependencias y actualiza el contenido del archivo composer.lock:

$ php composer.phar update

Este comando vuelve a resolver todas las dependencias del proyecto y guarda las nuevas versiones en el archivo composer.lock.

Si en vez de todas las dependencias solamente quieres actualizar unas pocas, puedes indicar su nombre después del comando:

$ php composer.phar update vendor/package vendor/package2

También es posible utilizar comodines para actualizar varios paquetes fácilmente:

$ php composer.phar update vendor/*

4.5.1. Opciones

  • --prefer-source: actualiza los paquetes utilizando la información de source, si está disponible.
  • --prefer-dist: actualiza los paquetes utilizando la información de dist, si está disponible.
  • --dry-run: simula el comportamiento del comando sin hacer nada. Esta opción es ideal para probar qué va a hacer la actualización de las dependencias sin llegar realmente a actualizarlas.
  • --dev: actualiza también los paquetes indicados en la opción require-dev (este es el comportamiento por defecto de Composer).
  • --no-dev: no instala los paquetes indicados en la opción require-dev.
  • --no-scripts: no se ejecutan los scripts definidos en el archivo composer.json.
  • --no-custom-installers: no se ejecutan los instaladores personalizados.
  • --no-progress: no se muestra de forma actualizada el progreso de la actualización. Esto evita los problemas de las consolas y de los scripts que no son capaces de manejar bien algunos caracteres especiales utilizados para indicar el progreso de la actualización.
  • --optimize-autoloader (-o): mejora el rendimiento de la aplicación convirtiendo la carga automática de clases de PSR-0 en un mapa de clases. Esta opción se recomienda ejecutarla en el servidor de producción. Como crear este mapa de clases consume un tiempo no despreciable, esta opción está desactivada por defecto.
  • --lock: solamente se actualiza el archivo composer.lock para eliminar los mensajes de error que indican que el archivo ha caducado.