Ver índice de contenidos del libro

1.3. Requerimientos

Composer requiere de PHP 5.3.2 o superior para poder funcionar. También se requieren determinados valores para algunas opciones de configuración de PHP, pero el instalador de Composer ya te irá diciendo todos los problemas que se encuentre para que puedas corregirlos.

Además, para instalar paquetes mediante su código fuente en vez de mediante archivos ZIP, es necesario que dispongas de las herramientas de control de versiones adecuadas: git, svn, hg, etc.

Por último, Composer es una herramienta multi-plataforma, por lo que funciona igual de bien en servidores Windows, Linux y Mac OS X.