Problema traduccion Symfony.

Buen dia/tarde/noche a la comunidad de libros web.

Mi problema es el siguiente:

Cree un proyecto de symfony con el objetivo de aprender un poco mas sobre algunos bundles muy utiles que he visto y me interesan, he agregado EasyAdminBundle a mi proyecto y lo he configurado de forma correcta y funciona, pero a la hora de limpiar el cache de la aplicación me sale este error:

[Symfony\Component\Translation\Exception\InvalidResourceException] Invalid resource provided: "1.2"; Errors: [ERROR 1871] Element '{urn:oasis:names:tc:xliff:document:1.2}target': This element is not expected. Expected is one of ( {urn:oasis:names:tc:xliff:document:1.2}context-group {urn:oasis:names:tc:xliff:document:1.2}count-group, {urn:oasis:names:tc:xliff:document:1.2}note, {urn:oasis:names:tc:xliff:document:1.2}alt-trans, ##other{urn:oasis:names:tc:xliff:document:1.2}* ). (in file:/C:/xampp/htdocs/LaravelNet/ - line 149, column 0)

Ademas de eso he mirado el log en la parte de desarrollo y me aparecen estas dos informaciones:

[2016-12-31 12:08:41] php.INFO: Using a colon in the unquoted mapping value "Изпратихме писмо с линк за активация на посочения E-mail адрес: %email%. Ако не откривате писмото проверете и в папка СПАМ." in line 42 is deprecated since Symfony 2.8 and will throw a ParseException in 3.0...."

[2016-12-31 12:08:41] php.INFO: Using a colon in the unquoted mapping value "Изпратихме писмо с линк за активация на посочения E-mail адрес: %email%. Ако не откривате писмото проверете и в папка СПАМ." in line 61 is deprecated since Symfony 2.8 and will throw a ParseException in 3.0....

El texto de los sucesos es mas largo todavía, solo he agregado lo que a mi parecer es importante, he mirado los archivos de traducción tanto en FOSUserBundle y EasyAdminBundle pero ninguno coincide con que el error me indica ademas de no decirme en que archivo ocurre el suceso.

Me gustaria saber como puedo solucionar esto, agradeceria su ayuda.

Un saludo.

Respuestas

#1

Hola,

En el archivo config.yml revisa estos parametros:

framework:
  translator:      { fallbacks: ["%locale%"] }
  default_locale:  "%locale%"

Obviamente en el archivo parametesr.yml debe existir el parametro locale.

Saludos,