Configuración de bundles dependientes

Hola, tengo un bundle que lo instalo con composer, este bundle requiere de otros como son rabbitmqBundle, JmsSerializer..., al meter la configuración por ejemplo del JMSSerializer en mi proyecto app/config.php me lanza un error: Symfony\Component\DependencyInjection\Exception\InvalidArgumentException: There is no extension able to load the configuration for "jms_serializer"

Entonces, cuando tengo mi bundle instalado y requiere la configuración de otros, ¿como se debe hacer?, miro otros Bundles y no veo que lo añadan en ningún lado.

Un saludo!!

Respuestas

#1

Adicionaste la referencia a los nuevos bundles instalados en el app/AppKernel.php de tu aplicación?

new JMS\SerializerBundle\JMSSerializerBundle(),
new OldSound\RabbitMqBundle\OldSoundRabbitMqBundle(),
....
#2

@RoberRielo, no, no lo tengo puesto en mi aplicación, no tengo entendido que deba poner esto en mi aplicación si en verdad en un bundle el que usa esas dependencias, no es mi aplicación en si, mi aplicación usa un bundle (creado por mi) que requiere otros bundles de terceros.

No sé esactamente como debe ser la verdad, pero veo otros como KNPPaginator y no requieres que añadas más que su bundle en el kernel, o sin ir más lejos el de Rabbit.