Symfony 2.7 en Heroku

Hola que tal estoy tratando de hacer de funcionar mi aplicación hecha en Heroku mi para mi aplicación uso Symfony 2.7 y Postgresql pero me dan los siguientes errores luego de ejecutar:

$ git push heroku master

me genera lo siguiente: Print del Error

ya he googleado pero no logro encontrar la solución, alguien que le haya sucedido lo mismo y sepa porque dan esos errores ??

Respuestas

#1

Hola @javiereguiluz no conoces algo de este tema ??

#2

Hola @OXRL, creo que tu problema tiene que ver con que no tienes correctamente configurada la conexión con la Base de Datos. Tengo entendido que en Heroku debes agregar servicios o Add-Ons (que son pagos pero tienen versiones gratuitas), que te dan por ejemplo posibilidad de usar una Base de datos PostgreSQL o MySQL.

Una vez que accedas a ese Add-On, desde el mismo podras obtener la direccion del servidor de base de datos que te ofrecen (o sea que ya no seria localhost). Debes configurar todo para así poder acceder correctamente. Este link quizá pueda ayudarte. Saludos

#3

Si tengo agregado correctamente Postgresql y creo esta configurado bien la conexión para acceder a la base de datos Imagen la verdad ya no se que hacer me tiene cabezón no poder subir mi aplicación

#4

Hola @OXRL,

esto es solo una idea, alguna vez tuve inconvenientes con una conexión a una base de datos diferente de mySQL.

En parameters.yml le especifiqué el driver con:

database_driver:    pdo_pgsql
#5

Hola gracias por responder le acabo de agregar y sigue saliendo lo mismo :(